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effects in this package are diverse, but FE 
Cylinder is a good representative. Once 
you’ve explored the tools and methods in 
this project, you’ll easily pick up the other 
effects.

Getting Started

In this project, you’ll apply the FE 
Cylinder effect to wrap some text around 
a 3D cylinder. You’ll make adjustments to 
enhance the three-dimensional 
appearance of the text. And finally, you’ll 
animate the cylinder to rotate the text in 
3D space.



  

Lesson 1: Opening the Project

       

Lesson 2: Applying the FE 

         

If you chose to segregate Final Effects 

Complete to their own sub-menu 

during installation, you’ll need to 

choose 

 

Effects> Final Effects> 

 

FE Cylinder

 

.

 

After Effects applies the effect to the 
layer and displays the Effect Controls 
window.

   

he Effect Controls window has all the tools you 
ed.
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To help you complete the tutorial more 
quickly, a project file has been created for 
you.

To open the project file:

1. Launch Adobe After Effects and open 
the Tutorial folder: Cylinder Project 
file.

The actual project file has a black 
background, the file displayed here 
has a white background because it 
prints more clearly.

Cylinder Effect

Now that you have a basic file you can 
begin by applying an effect to the project.

To apply the FE Cylinder effect:

1. In the Time Layout window, select 
the “tutorial logo” layer.

2. Choose Effects> Perspective> 
FE Cylinder.This is what the project file looks like when you 

open it.

The layer window lets you see and edit all the 
layers in your file. T

ne
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Lesson 3: Resize the Cylinder

       

 change the view of the effect:

  

Press the Shift key and drag the 

 

Scrubber: Rotation trackball

 

 
straight down.

   

 the Rotation trackball to change your view 
he cylinder.
The effect window has several controls 
that let you adjust the properties of the 
cylinder. In this lesson you’ll use the 
radius slider to increase the size of the 
cylinder.

To resize the cylinder:

1. Drag the Radius slider to increase the 
size of the cylinder.

The edges of the text should 
approach the sides of the frame, but 
you want to leave a little margin.

Lesson 4: Changing Your View

Although the text is wrapped around the 
cylinder, it might not look like it at first. 
The default view is straight on. To see the 
effect batter you’ll have to change the 
view.

To

1.

The radius slider controls the size of the cylinder.

Your text is wrapped around the circumference 
of a cylinder.

Use
of t



  

Using the Shift key constrains 

   

You can minimize delay by doing 
most of your settings work in Draft 
layer quality and reduced resolution 
in the Composition window. When 
you’re ready for final output, switch 
to Best quality and full resolution. 
Refer to your Adobe After Effects 
documentation for information on 
layer Quality settings and 
Composition window resolution.

 

.

 

Save the project now.

u’ll notice that the view is still not in 
e best position to view the cylinder. You 
n rotate the camera around is vertical 
is to get a better view. 

 

 rotate the camera around the 
ylinder:

 

.

 

Expand the Y Rot control to see the 
radial control.

 

.

 

Click in the dial to change the setting.
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movement according to the direction 
you start dragging.

The Scrubbers are indirect 
manipulation tools. You drag them 
to change the position or orientation 
of the view camera. 

If you look lower in the window, 
you’ll see that the X Rot value has 
increased. The Rotation trackball 
consolidates the X Rot, Y Rot and Z 
Rot controls into a single tool. 

The X axis is horizontal. A positive 
value tips the cylinder toward you.

If you put an extreme tilt to the 

camera, the text might be clipped by 

the edge of the layer. If this happens, 

you can use the Position + scrubber to 

move the cylinder vertically within the 

layer. Drag the + icon in the direction 

you need to move the cylinder.

The Position controls don’t move the 

layer. They move the cylinder within 

the layer.

Notice that after making a change, it 
takes a moment to render the image. 
While you’re waiting, a “progress 
snake” slithers around the time code 
display at the bottom of the 
Composition window. When the 
snake is gone, the effect is rendered. 

The effect rendering time depends on 
the resolution of the layer and 
composition, complexity of the 
effect, Quality setting and the speed 
of your system.

2
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Use the Rotation scrubber to rotate the camera.

This is what the Rot X value should look like 
when you’re done.

The “progress snake” lets you know how long it 
takes to render an effect.
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Lesson 5: Enhancing the 3D 

      

You may want to change the Y Rot to 
view the cylinder from different 
angles to check this effect. Use either 

   

th a high Camera Lens Angle setting, letters 
the back side of the cylinder are smaller than 
se on the front.

th a Camera Lens Angle setting of 0.0, the 
t appears at the same scale on the front and 
k.
Y Rot describes the view camera’s 
rotation around the vertical axis. As you 
move the camera, you’ll see different 
views of the cylinder.

Perspective

The Camera Lens Angle controls the 
foreshortening effect. By adjusting the 
value of this parameter, you can change 
the 3D appearance of your cylinder.

To adjust the cylinder’s foreshortening:

1. Use the Camera Lens Angle slider to 
increase the setting. 

This parameter controls the 
foreshortening effect—scale 
diminishes as distance increases.

 

Rotate the camera for a different view of the 
cylinder.

Use the Camera angle slider to adjust the 
foreshortening effect.

Wi
on 
tho
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the Y Rot control or drag the 

     

• Enter zero as the Ambient light 
value and OK the dialog.  

 

.

 

Set Diffuse light at 0.7.

• Click the Diffuse value display.

• Use the dialog to enter 0.7 as the 
Diffuse light setting.

    

ith no light, the text will be very dark.

ith the Diffuse light the only source of 
umination, the shading contrast is strong.
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Scrubber: Rotation trackball 
horizontally (with Shift down).

The Render pop-up lets you choose 
which faces of the cylinder are 
visible—Full, Outside or Inside.

Lesson 6: Adjust Lighting

The Ambient, Diffuse and Specular 
sliders combine to produce a 3D lighting 
environment. The lighting contributes to 
the cylinder’s curved appearance with 
shading and highlights.

Instead of expanding the controls and 
using the sliders, we’ll set the lighting 
parameters numerically.

To set lighting parameters numerically:

1. Turn off Ambient light.

• Click the Ambient value display.

• A dialog appears, giving you the 
opportunity to set Ambient light 
numerically.

2

  

This is what the cylinder looks like rendering 
only Inside.

This is what the cylinder looks like rendering 
only Outside.

This is what the cylinder looks like using Full.

W

W
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The highlight depends on light 

         

• Drag the slider to set the light’s Z 
position.

u’ll get a nice, front-left lighting with 
ht Direction set at -140° and Light 
pth set at 0.1.

  

Before continuing, save your work.

 

sson 8: Animating the Cylinder

 

this lesson, you’ll set key frames to 
ate the cylinder. The text will appear to 
ve in an orbit.

 

 animate the cylinder:

  

Make sure the current time is 
rewound to 0:00.

  

now, the loop of text should be looking pretty 
d. 
You can turn up the Ambient light a 

little to fill in the shadows.

3. Increase the Specular setting slightly.

The Specular parameter controls the 
concentration of the highlight.

  

direction. You’ll set direction in the 
next step.

The Roughness control controls the 

spread of the highlight.

Lesson 7: Setting Light Position

Two parameters control the light’s 
aim—Light Direction and Light Depth. 

Light Direction controls the light’s 
direction in the X, Y plane. 

Light Depth controls the lights position 
in the Z dimension.

To set light position:

1. Set Light Direction.

• Display the Light Direction 
control.

• Click in the dial to change light 
direction.

2. Set Light Depth.

• Display the Light Depth control.
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The highlight is the white streak on the cylinder 
where the light reflects directly.

Specular = 1.5

Specular = 0.77

By 
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2.

 

In the Time Layout window, expand 

          

Changing a key framed parameter at 

             

If this test render looks good, you can set 
e layer Quality to Best and the 
mposition resolution to Full. Then 
ake the movie again.

 you’re not getting the results you want, 
 back and change the settings.

 

esson 10: Adding the Final 
ouches

 

u can take this project a step further 
d have the text orbit an object. This is 

one with layering and a tricky use of the 
ender display option.

 

 split the Inside and Outside of the 
ylinder into two layers:

 

.

 

Make your final adjustments to the 
FE Cylinder animation.

 

.

 

In the Time Layout window, copy the 
“tutorial logo” layer. Deselect that 
layer, then choose Paste.

After Effects adds a second copy of 
the layer to the composition. This 
copy includes the FE Cylinder effect 
and all of its adjustments.

 

.

 

Select the top layer. In its Effect 
Controls window, set the Render 
pop-up to display Outside.
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the “tutorial logo” layer properties.

3. Locate the FE Cylinder property and 
expand it.

Locate the Y Rot listing. You may 
need to scroll down the window.

4. Click the stopwatch beside the Y Rot 
listing. 

This sets a key frame for the current 
Y Rot value. You may adjust the value 
now to change the animation start 
orientation.

5. Advance to the frame at four seconds 
(04:00).

6. Click the Y Rot value in the second 
column of the Time Layout window.

7. Use the dialog to set Y Rot 
revolutions to 1.0. Leave the degrees 
as they are.

any other point creates a key frame.

These key frames will animate the 
camera to rotate around the cylinder 
once in the first four seconds.

Lesson 9: Test Rendering the 
Animation

Now that you’ve set up the animation, 
you can make the movie and check how 
your key frames look. 

To render the animation:

1. Choose Composition> Make Movie.

2. Name the file and choose a save 
location.

3. Use the Render Queue dialog to 
adjust rendering settings, if necessary.

4. Click Render, and wait for your 
movie.
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The expanded display shows all of the 
animatable parameters. 

As you create key frames, they appear on a 
parameter’s line.
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Adding an item into the Time Layout 

    
To change effect properties, select that 

layer, then use the Effect Controls 

window. If a layer’s Effect Controls 

window isn’t visible, you can open it 

from the Layer menu.

4. Select the lower layer and set it to 
Render only the Inside.

Because the FE Cylinder parameters 
(except the Render face) are identical in 
the two layers, they match and appear as 
one.

To add the central object:

1. In the Project window, locate the 
“planet” footage file.

2. Drag the “planet” into the Time 
Layout window.

window centers it in the 
composition. If you need to, you can 
reposition the layer.

3. In the Time Layout window, drag the 
“planet” layer between the two 
“tutorial logo” layers.

The inside of the cylinder is behind the 
planet, and the outside of the cylinder is 
in front of it. When you render the 
animation, the text will orbit the planet.

The two cylinders overlap. One shows its front, 
the other shows its back.

The text orbits the planet.
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